Wings 3D Has a GUI Problem on my builds of Linux.

In keeping with my recent theme, of testing various 3D editing applications available under Linux, I next tried out “Wings3D”, which is available in the Debian repositories / package manager.

And one detail which I found frustrating, was that some of the dialog boxes – if not all of them – have problems displaying correctly on the current build of Linux.

I get the impression that Wings3D is actually quite powerful. But unless the Right-Mouse-Button (‘RMB’) clicks reveal their full Context Menus, it can be hard to get started with this application.

There was just a specific exercise which I undertook this evening, which was to try assigning a custom material – and therefore an arbitrary texture image – to an arbitrary 3D model, even in a situation where the texture image made no sense, just to get a feel for how it’s done. While getting started with this, I learned that objects must be U,V-mapped first – which is actually nothing new. And, advanced 3D editors such as Wings3D, do have a semi-automatic U,V-mapping option. The trick is for a person who has never used Wings3D before – actually to find it!

We can select a model to work on, and then we’re supposed to RMB, and from the context-menu, pick the ‘UV-Editor’. The problem with my build of Linux is, that the last entry of the context-menu is actually this option, and it doesn’t display correctly! Instead, in its place, all we get to see is a dot. When I’m looking for a UV-Editor option in a context-menu, to UV-Edit a specific model, I don’t usually think, that the entry which is actually displaying As A Dot – Is It.

wings3d_3

Once I discovered this detail, I was able to make progress by trial-and-error.

There is a way for users in general to make out the entries in the Wings3D context menus, that are not being displayed correctly, and that is to hover over those entries, and to observe what the bottom, green bar tells us. It will update, and display information about how to use the menu-entry being hovered over – including what that entry is called ! :-D

Dirk

(Edit 08/24/2017 : )

I solved this problem, by upgrading to the latest version of the application.

For Debian / Jessie, the package manager only offers version 1.5.3 . But we can actually install version 2.1.5 quite well, from the Web-site.

 

wings3d_6

 

wings3d_7

 

Print Friendly, PDF & Email

Leave a Reply

Your email address will not be published. Required fields are marked *

Please Prove You Are Not A Robot *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>