A Glitch in the Roku

The , like many home appliances today, periodically downloads firmware updates, designed to fix glitches. Yet, it might be helpful for its developers to know what all of them are – and what they have yet to fix.

(Edit 05/11/2017 : The status of this glitch or bug has been superseded, by a firmware update which took place since the time of this posting, and which I’ve written about in this later posting. The bug seems to have been fixed. )

One feature the has, which I have described before, is its ability to use the HDMI interface, to tell the TV, to make it the selected input, as soon as we operate any controls. My TV has 3 HDMI inputs, and all 3 are currently connected to some sort of appliance.

calls this feature “One-Touch Play”.

Samsung calls it ““.

The problem becomes noticeable, if we leave the TV input switched to the , turn off the TV, and then simply allow the to go into standby, at some later point in time.

What happens is that as it goes into standby, the ‘remembers’ that it was the selected input of the TV. This may in fact not be the case anymore, when we next want to use the , because by then, we may have switched the TV input to something else. But, when the resumes, it still ‘thinks’ it is the selected input, and fails to send the signal to the TV again, to make itself the selected input.

This problem can lead to confusion until the cause is identified, and carries on in a very persistent way. When we have multiple remotes, being able to understand what each of them does may no longer be satisfying. We may actually want to keep their operation as direct as possible as well.

IMHO, The correct behavior would be, that the forget it was the selected input, and that it resend the signal to the TV anyway, to select itself, as soon as a control is pressed.

I have been able to create another similar situation, in which the was simply on its home-page, after viewing video for an hour or more, and in which to switch the TV to a different input – using the TV remote – did not send the message to the , that the was being disconnected.

Actually, I can tell whether this feature is working correctly or not, while I switch the TV to another input, before shutting everything down. When things are working, my TV displays a message saying ““. This tells me that the TV is sending the signal to the as well, telling the latter, it is no longer the selected input.

This only happens with the , not with the Sony Blu-Ray player, which suggests that it may still be a glitch with the .

Dirk

This bug exists with

(Edit 02/15/2017 : )

The other situation in which this glitch occurs is as follows.

The could be on its Home Page, and I could use my TV remote, to switch the TV to a different input. At that time, the TV Menu does display the word “” next to the currently-chosen input. Then, I can switch the TV off.

If the has not gone into standby yet – i.e., its white LED is still lit – and I use the remote both to Turn On the TV, and to allow the to Recapture the TV input, this next works. But after that, the next time I use the TV remote to switch its input to another input, first of all,

  • The TV Menu no longer displays the word “” next to the currently-chosen input, and
  • After that, using the remote no longer recaptures the TV input.

Dirk