NG-SPICE: A Problem with the Model-Cards, and the MOSFET-Sizes, mentioned on this blog.

I’ve discovered that the version of SPICE installed on my computers is so old that the version caused a kind of malfunction. It did not allow for the specification of channel width and length on the ‘.MODEL’ line, requiring instead that these parameters be defined per-instance in the net-lists, i.e., in the circuit-files that used these components.

What I had done was to set the channel-length to 1.5u and the width to 1u, in the Model-Cards that I published on this site, hoping that to do so would standardize the behaviours of anybody trying to reproduce my results. But this had the opposite effect, in that my software failed to read the parameter at all, while the result for readers of my blog could have been that their software-version read them.

The error-messages of my software, stating that the parameters were not being read, went unnoticed somewhere amongst reams and reams of messages.

The default is 100u for both parameters, which would also be 1.0e-4 .

Dirk

 

Print Friendly, PDF & Email

One thought on “NG-SPICE: A Problem with the Model-Cards, and the MOSFET-Sizes, mentioned on this blog.”

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

 

This site uses Akismet to reduce spam. Learn how your comment data is processed.